Service Interruption
Incident Report for Showit
Resolved
This issue has been fully resolved.
Posted Apr 12, 2024 - 08:06 MST
Update
We are continuing to work on a fix for this issue.
Posted Apr 12, 2024 - 07:55 MST
Identified
We've identified an issue affecting some of our blog servers and are currently investigating.
Posted Apr 12, 2024 - 07:38 MST
This incident affected: Blog Hosting.